You should upgrade your Google Chrome ASAP! Here’s why!

If you use Google Chrome browser for your daily internet spree, you need to update it right away, in case you haven’t.

Google has revealed that there is a zero-day vulnerability in its browser which attackers are ‘actively exploiting’, Engadget reported.

ALSO READ: Now, YouTube to add fact checks to controversial search topics

What makes the security vulnerability different from previous exploits is that the browser needs to be restarted for the fix to take effect. To ensure safety, ensure you are updated to the latest version 72.0.3626.121 that comes with the fix.

Those using the browser on a Windows OS are in for double the trouble as Google revealed that the bug was being used in concert with a second vulnerability in the system. The issue may impact those running windows 7 32-bit systems.

If you are still using the old system, it is recommended to move to a newer version of the OS or install the security patches.

(With ANI inputs)

Click here for Latest News updates and viral videos on our AI-powered smart news genie

LEAVE A REPLY

Please enter your comment!
Please enter your name here